If the "last updated" date is very recent please delete the mod completely and download the new version.